So, dann hier ein wenig „Technisches“ zu der Kamera. Das Beschlagene hat sich gelegt und sie liefert nun beste Bilder. Das Wetter ist aber auch Perfekt. Ein „es ist vollkommen Dunkel“-Wolkenmix und „Ich blende dich bis du nix mehr Siehst“-Sonnenwetter.

Zuerst das Negative: Das Kabel. Es ist nur gute 75cm Kurz:

IMG_20130220_083606

Hier gut zu sehen, wie Kurz es ist und wie Dünn meine Wändchen sind. Um Das kabel nach innen zu legen, müsste ich mit meinen 26er Bohrer ein Löchlein von beiden seiten Bohren, da der Bohrer nicht ganz durch passt. Dann habe ich nen 26er Loch mit einen 10mm Kabel drin. Alles dann Verputzen. Wenn dann was ist, die Wand aufstemmen. Geht nicht, Hatte ich aber im Vorfeld schon bemängelt und wusste, das es (vielleicht) so kommen wird:

IMG_20130220_095759

Weiter negativ ist mir die Halterung aufgefallen. Ich glaube, so richtig fest bekommt man die Kugelkopfgelenkgeschichte nicht wirklich, aber ich lasse mich überraschen!

(so, ab hier vergingen ein paar Stunden, deswegen nicht wundern, das ich gaanz unten das nochmals aufgeführt habe als Bestätigung für meinen Verdacht!)

So, die Einrichtung im eigentlichen war recht easy. LAN anschließen, Power auf die Leitung und kurz warten. Da ich ein Debian-User bin, habe ich darauf verzichtet die CD einzulegen und die Kamera so einzurichten, wie es vorgeschlagen wird. Mit der Such-Software. Hier reichte ein
ping -b 10.0.0.255, (hier hab ich mal beschrieben, was das ist.) So bekam ich raus, das die Kamera die 10.0.0.115 bekommen hat. Ein Blick ins Webinterface von der Fritzbox zeigte es auch:
IP-Adresse-Kamera
So war es an der Zeit, das Webinterface aufzurufen (Username und Passwort stehen auf den Aufkleber unter der Kamera!) und mal schauen, was mich erwartet. Oh schreck, oh grauß, ein Absolut Verschwommenes Bild… Was war Passiert? Kaputt? Doch nicht so Toll? Naja, ich hatte die hier im Dezent warmen Wohnzimmer (bin erkältet und es kann mir dann nicht warm genug sein!) und habe sie dann zum Testen ans offene Fenster gestellt. Nach dem der Schleier Verschwunden war, sah es so aus:
kamera_etwas_verzerrt

 

Das Webinterface gefällt mir soweit, es ist Einstellbar auf Deutsch und bietet viele Funktionen.
(Viele brauche ich nicht, da das eh alles mein Server regelt, dazu später mehr. )
kamera_webinterface_deutsch

 

 

 

kamera_backup_restore
Das gefällt mir besonderst gut. Einstellungen sichern und zurückschreiben. Das ist das, was (die) edimax nicht wirklich auf die Kette bekommen hat. Reset = alles weg. Ach ja, Links das „Benutzer Einstellungen“ und „Benutzer Einstellungen“ … Das obere ist Kamera-Name, das untere eben Benutzereinstellungen. Etwas Verwirrend am Anfang, aber wenn man es weiß… (Nach dem 30ten male klickt man meistens richtig!).

Auch die DynDNS einstellungen gefallen mir, nicht nur DynDNS und unbekannte Dienste, sondern auch No-IP!
Was etwas merkwürdig ist und ich nicht zu 100% nachvollziehen kann, sind die FTP-Settings:
kamera_ftp_FAIL
Ich stelle ein, dass das Bild „aktuell“ heißen soll, und erwarte also aktuell.jpg und die Kamera macht daraus nen aktuell_1.jpg… gut, das mag daran liegen, dass das Kamera 1 ist, dennoch hätte ich gern „aktuell.jpg“ gehabt. Musste einige HTML-Sktipte umschreiben, aber was solls :)

Bei den email-Einstellungen das machen, was da steht und nicht das machen, was man meint, was richtig ist…
„Bitte nehmen Sie alle Einstellungen vor, bevor Sie mit dem Test beginnen.“
Sprich: alles eintragen, „Übernehmen“ klicken und dann Testen. Anderstrum als man es gelernt hat :)
(macht man es „richtig rum“ gibt es nen Fehler!)

Die Motion-Detection kann ich hier nicht Verwenden. Leider. Ich hatte die Kamera anfangs so, das ich .. schaut selbst, wie es aussah, als es Dunkel wurde:
kamera_geht_nicht

 

Also musste ich die Kamera etwas drehen, sieht dann so aus:
kamera_nacht_per_motion
Die Bewegungserkennung regel ich jetzt mit Motion und einem PGM-Overlay. Dazu aber, wie geschrieben, in einen späteren Artikel mehr.

 

Als die Kamera noch so hing, klappte das allerdings mit der Bewegungserkennung :)
ERKANNT

 

Mit der Nachtsicht bin ich vollkommen zufrieden!
Screenshot_2013-02-21-00-29-28
Das ist ein Screenshot von „IPCamViewer Basic“ auf meinen Android-Tablet (steht neben dem PC und schiebt sonst nur Langeweile!) Gerne hätte ich noch mehr von der Wand links gesehen, also weiter (Ich will endlich mal nen Sprayer oder nen Scheibeneinschläger erwischen!) – aber leider ist das Objektiv doof :)

Stresstest: Ich habe die Kamera auch einen kleinen Stresstest durchlaufen lassen. Jeder Client hier hat intern und per WAN auf die Kamera zugegriffen, also das Live-Bild empfangen. Zusätzlich durfte die Kamera noch jede Sekunde ein Bild aufm FTP schieben (auch im LAN) und mein Server extern hat per WGET den Livestream gezogen. Es hat nichts gezuckelt oÄ. Und das per WLAN. Die Edimax ist bei diesem Test gestorben und war 20 Minuten unerreichbar :D

 

So, Negatives….
– Von der Edimax bin ich es gewohnt, das es ein direktes jpg-Bild gibt, welches ohne Login erreichbar ist. Nannte ich meist „loginfree.jpg“, kann die Kamera nicht. alles nur CGI. Das kann mein olles Sony-Ericsson T280i nicht.
– Wie gehabt, das viel zu kurze Kabel mit dem viel zu dicken Stecker!
– Die Halterung. Eine Katastrophe! Die Idee ist ja ganz nett, aber wie ich befürchtet habe, bekommt man die Kamera damit einfach nicht fest. Und wenn man es doch geschafft hat, dann hat sich die Schraube am Fuß gelöst und die ganze Kamera kippt nach vorn.
– Rotate-Image. Ich hatte die Kamera probeweise mal „seitlich“ montiert. in der motion.conf (dazu schreibe ich gerade Parallel noch nen Artikel) kann ich image-rotation einstellen. 90° und so, auch bei dem ip Cam Viewer für Android kann ich sagen: rotiere mal 90°. Leider kann das die Kamera nicht von selbst. Sonst könnte ich den kompletten gehweg bis zum Tor, also alles das, was hier zu gehört, einsehen.
– Die Software ( von CD „IPCamViewer“) läuft nicht, es kommt nur ein:
IPCamClient.exe.fehler.xp

 

Auf meinen GT-P1000 Tablet nutze ich „IP Cam Viewer Basic“, wenn ich als Vorgabe eben foscam und dann die FI8904w wähle, ist das ne PTZ-Kamera. Aber ich denke mal, das der Fehler beim Programmierer von IP-Cam-Viewer liegt :)

Ein erstes, vorsichtiges Fazit nach gerade mal ca. 12 Stunden: Sie läuft. Als Kamera bestens, will man mehr, ist es vielleicht nicht DIE erste Wahl. Wobei ich dazu sagen muss, das ich kein Anfänger am Computer bin und gewisse Vorstellungen von dem habe, was ich will. Klingt komisch. Ist auch so :)
Will sagen, das ich immer etwas erwarte, das keine Firma bieten wird!  (Darum habe ich mir zB auch meinen Receiver selbst gebastelt ^^)

So, das war es für heute erst einmal. Ach ja, was ich noch zur Verteidigung sagen muss, was viele im Netz bemängelt haben:
„Nach einen Reset ist die Kamera NICHT per WLAN erreichbar!“
Warum und wie auch? Die Kamera weiß ja nicht, wie sie sich warum und wo und überhaupt in welches Netz einloggen soll. DAS kann, so glaube ich, keine Kamera und kein Netzwerkgerät. Ich kenne zumindest keins, welches sich ohne zutun vom Besitzer (oder sonst wem) irgendwo einloggt :)

 

Technische Details erspare ich mir/euch, die findet ihr hier: http://www.foscam.de/shop/WLAN-UEberwachungskamera-24x-IR-LED-Wasserdicht